Plugin vulnerado en WordPress

plugin vulnerado

Una alerta en Internet alrededor del plugin jetpack y de la plantilla Twenty fifteen de WordPress se ha levantado en las últimas horas. Se trata de que estos componentes muy poopulares en WordPress, estarían vulnerados por un ataque XSS DOM.

Esta alerta la dio Sucuri quien descubrió esta vulnerabilidad que podría estar afectando alrededor de 1 millón de páginas web. Esta es la cifra que se estima utilizan el plugin jetpack.

En realidad la alerta se extiende a cualquier plugin que incluya el archivo example.html que suele venir con los genericons.

Dicho esto, una de las más simples soluciones para protegerse de esta vulnerabilidad, es eliminar dicho archivo del paquete genericons. Sucuri ha dado esta alerta apenas se inició esta vulnerabilidad  lo que significa que podemos tomar las medidas sugeridas o evitar instalar el plugin. De tenerlo instalado borrar el archivo example.com ya que de esta manera tendrás una respuesta rápida ante este ataque

En AQP no queremos estar al margen de esta alerta qué es importante para todos quienes usan este plugin bastante popular en WordPress.

El ataque se da a partir de las respuestas HTTP que no varía pero el código es ejecutado de modo diferente ya que esta vulnerabilidad XSS se da en el entorno de DOM

Para aquellos que quieren conocer detalles más técnicos describimos esta vulnerabilidad citando al sitio web Search Engine Journal

“El DOM-basado en XSS es un ataque XSS en el que la carga se ejecuta como resultado de la modificación del entorno Document Object Model (DOM)”  “en el navegador de la víctima utilizado el script original del lado del cliente, por lo que el código del lado del cliente se ejecuta de manera “inesperada”.

Es decir, la propia página (la respuesta HTTP) no cambia, pero el código de cliente que figura en la página, se ejecuta de manera diferente debido a las modificaciones maliciosas que se han producido en el entorno de DOM.”

WordPress es el CMS más popular lo que lo convierte en blanco de diversos ataques. Afortunadamente, así como hay atacantes, existen también defensores.

Gracias a la enorme comunidad de personas usuarios desarrolladores y empresas de software que colaboran con WordPress, podemos detectar los ataques a tiempo, esto nos ayuda a mantenerlo seguro lo que no hubiera sido posible en sitios desarrollados sin un CMS.

En un mundo donde los ciberataques son como el pan de cada día, WordPress y sus usuarios pueden dormir tranquilos a pesar de estas alertas, ya que Sucuri lo descubrió bastante rápido y nos da tiempo de defendernos

¿Usas Jetpack? Ya sabes cómo defenderte. 

Leave a Reply

Your email address will not be published.

×
¿Podemos Ayudarte?